Документы в 1С:Предприятие

В предыдущем выпуске рассылки была представлена 7 часть учебного материала по обучению 1С: Предприятие 7.7. Конфигурирование. Компонента «Бухгалтерский учет».

Мы уже начали изучать документы в 1С:Предприятие и рассмотрели создание «Приходной накладной».
Сегодня рассмотрим создание «Расходной накладной».

Задание. Создайте документ «Расходная накладная»
Процесс создания расходной накладной во многом совпадает с созданием приходной накладной. Скопируйте через буфер обмена ПрихНакл, переименуйте в РасхНакл и внесите изменения:
• В шапке реквизит «Поставщик» замените на «Покупатель» (тип Справочник.Организации)
• Поскольку реквизит «ЦенаПродажи» справочника «Товары» является периодическим, необходимо зафиксировать дату, на которую считываем значение этого реквизита. Внесите изменения в модуль формы документа:

Процедура ВычЦенуПоУмолч()
     Товар.ИспользоватьДату(ДатаДок);
     Цена=Товар.ЦенаПродажи;
КонецПроцедуры


Задание. Сформируйте печатную форму документа «Расходная накладная»
Воспользуйтесь для создания печатной формы конструктором печатных форм: меню Конструкторы>Печать.
• В первой части диалога выберите реквизиты шапки документа: НомерДок, ДатаДок, Покупатель;
• Далее - реквизиты таблицы: все;
• Далее - в подвале документа - Итог («ОбщСумма»);
• Новая кнопка «Печать», только просмотр.
Готово.

Задание. Отформатируйте печатную форму.
Форматирование осуществляется с помощью методов Формат() и символа #. Формат() может быть использован в любом месте программы (формула реквизита диалога, модуль, таблица). Решетка - только в таблице.
• Формат даты: ДатаДок #Д ДДММММГГГГ - возвращает дату документа в заданном формате - 2 цифры день, месяц прописью, год 4 знака.
• Цена #Ч15.2, Сумма #Ч15.2 - означает, что длина будет 15 символов, из которых 2 после запятой, целая и дробная части разделяются точкой, триады - запятой. Итог должен выводиться прописью. Формат(Итог(«ОбщСумма»), «ЧПДС»)

Модуль печати:
//{{ПРОЦЕДУРA_ПЕЧАТИ (Печать)
//Данный фрагмент построен конструктором.
//При повторном использовании конструктора, внесенные вручную изменения будут потеряны!!!
Процедура Печатъ()
     Таб = СоздатьОбъект("Таблица");
     Таб.ИсходнаяТаблица("Печатъ");
     Таб.ВывестиСекцию("Шапка");
     Таб.Опции(0,0,0,0);
     ВыбратьСтроки();
     Пока ПолучитьСтроку() = 1 Цикл
           Таб.ВывестиСекцию("Строка");
     КонецЦикла;
     Таб.ВывестиСекцию ("Подвал");
     Таб.ТолъкоПросмотр(1);
     Таб.Показатъ("Печать РНК", "");
КонецПроцедуры
//}}ПРОЦЕДУРА_ПЕЧАТИ
изменения в конфигураторе и проверьте работу в режиме 1С: Предприятие: Операции \ Журналы документов \ Полный \ Создать новый документ \ Расходная накладная.